Installing the latest .NET Framework for finPOWER Connect

TSB1035 | Thursday, 7 July 2016

This Technical Support Bulletin applies to finPOWER Connect 2.0 and later.

Overview

The Microsoft .NET Framework is a software component that includes of a number of services and libraries to provide a framework for applications to run on - this includes finPOWER Connect.

Issue

Various versions of the .NET Framework exist. Later versions include more functionality and fixes for issues within the framework.

It is important that you use a current version of the .NET Framework.

finPOWER Connect

  • finPOWER Connect 2.x requires the .NET Framework version 4.5 or later to be installed. Note, version 4.5.2 or later is the preferred version.
  • finPOWER Connect 3.0.x requires the .NET Framework version 4.5 or later to be installed. However, it is strongly recommended you install version 4.6.1 or later.
  • finPOWER Connect 3.1.x requires the .NET Framework version 4.6.1 or later to be installed. However, it is strongly recommended you install version 4.7.1 or later.

For more information see finPOWER Connect System Requirements.

To check what version of the .NET framework you have installed, open finPOWER Connect and go to Help, About finPOWER Connect.

finPOWER Connect 2.x will include a line like "Microsoft .NET Framework, version 4.0.30319.34014". The versions are not easy to understand, as various Windows updates may update the version. Some major versions are listed below:

finPOWER Connect 3.x will include a line like "Microsoft .NET Framework, version 4.6.1".

4.0.30319.1.NET Framework 4.0 RTM
4.0.30319.17929 .NET Framework 4.5 RTM
4.0.30319.18408.NET Framework 4.5.1 on Windows Vista/7
4.0.30319.34014.NET Framework 4.5.1 on Windows 8.1
4.0.30319.34209.NET Framework 4.5.2
4.0.30319.42000.NET Framework 4.6, 4.6.1 and 4.6.2

Installing the latest .NET Framework

To install the latest version of the .NET Framework go to https://www.microsoft.com/net/download.

Please review System Requirements and other Notes first.